Commit 941acad6 authored by Chase Qi's avatar Chase Qi
Browse files

doc: install latest version docker and docker-compose



The current version '18.09.1' docker installed via 'apt install
docker.io' doesn't work with 'lava-docker-worker'. The below error
returned.

```
docker: Error response from daemon: OCI runtime create failed:
container_linux.go:344: starting container process caused "exec:
\"/dev/init\": stat /dev/init: no such file or directory": unknown.
```

While the '20.10.5' version from Docker's official repo works well with
'lava-docker-worker'

Old version docker-compose also is problematic in some cases.
Signed-off-by: default avatarChase Qi <chase.qi@amd.com>
parent c0ed4828
......@@ -52,6 +52,15 @@ URL="https://my.lava.server/"
TOKEN="--token 0123456789012345678901234567890123456789"
```
Make sure Docker get installed from Docker's official repo. At the time of
writing this doc, Docker version `18.09.1` installed from Debian's official
repo doesn't work with `lava-docker-worker`.
```
curl -fsSL https://get.docker.com -o get-docker.sh
sh get-docker.sh
```
Then enable and start the `lava-docker-worker` service:
```
......
......@@ -20,20 +20,12 @@ Install the dependencies: `docker` and `docker-compose`:
```shell
apt-get update
apt-get install docker.io docker-compose git
apt-get install python3-pip git
curl -fsSL https://get.docker.com -o get-docker.sh
sh get-docker.sh
python3 -m pip install docker-compose
```
??? tip "Old Debian version"
On old Debian versions, docker should be installed from the official docker repository.
```shell
apt-get install ca-certificates gnupg2 wget
wget https://download.docker.com/linux/debian/gpg
apt-key add gpg
echo "deb [arch=amd64] https://download.docker.com/linux/debian buster stable" > /etc/apt/sources.list.d/docker.list
apt-get update
apt-get install docker-ce
```
### Install
Get the **docker-compose** files from [gitlab][lava-docker-compose] and use it.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment