Commit 530ad377 authored by stevanradakovic's avatar stevanradakovic
Browse files

Update django minimum version to 2.2

Use Django from buster-backports as 1.11 is now deprecated.
parent d304f9b6
Pipeline #9736 passed with stages
in 16 minutes and 56 seconds
......@@ -11,7 +11,7 @@ RUN echo 'deb http://deb.debian.org/debian buster-backports main' > /etc/apt/sou
apt-get update -q && \
apt-get install --no-install-recommends --yes apache2 gunicorn3 postgresql postgresql-client postgresql-common python3-setuptools && \
apt-get install --no-install-recommends --yes python3-voluptuous python3-yaml && \
apt-get install --no-install-recommends --yes python3-aiohttp python3-celery python3-django python3-django-auth-ldap python3-django-filters python3-django-tables2 python3-djangorestframework python3-djangorestframework-extensions python3-djangorestframework-filters python3-docutils python3-eventlet python3-jinja2 python3-junit.xml python3-psycopg2 python3-requests python3-simplejson python3-tap python3-tz python3-voluptuous python3-whitenoise python3-yaml python3-zmq && \
apt-get install --no-install-recommends --yes -t buster-backports python3-aiohttp python3-celery python3-django python3-django-auth-ldap python3-django-filters python3-django-tables2 python3-djangorestframework python3-djangorestframework-extensions python3-djangorestframework-filters python3-docutils python3-eventlet python3-jinja2 python3-junit.xml python3-psycopg2 python3-requests python3-simplejson python3-tap python3-tz python3-voluptuous python3-whitenoise python3-yaml python3-zmq && \
apt-get install --no-install-recommends --yes python3-pip && \
python3 -m pip install sentry-sdk==0.17.2 && \
find /usr/lib/python3/dist-packages/ -name '__pycache__' -type d -exec rm -r "{}" + && \
......
......@@ -5,7 +5,7 @@
{% set dependencies = [
{"pkgs": "apache2 gunicorn3 postgresql postgresql-client postgresql-common python3-setuptools" },
{"pkgs": requires("debian", "buster", "lava-common") },
{"pkgs": requires("debian", "buster", "lava-server") },
{"pkgs": requires("debian", "buster", "lava-server"), "from": "buster-backports" },
] %}
{% set pip_packages = ["sentry-sdk==0.17.2"] %}
......@@ -19,7 +19,7 @@ lava-server:
version: ">=1.14.2"
name: python3-django-tables2
django:
version: ">=1.10"
version: ">=2.2"
name: python3-django
djangorestframework:
name: python3-djangorestframework
......
......@@ -19,7 +19,7 @@ lava-server:
version: ">=1.21.2"
name: python3-django-tables2
django:
version: ">=1.10"
version: ">=2.2"
name: python3-django
djangorestframework:
name: python3-djangorestframework
......
......@@ -19,7 +19,7 @@ lava-server:
version: ">=1.14.2"
name: python3-django-tables2
django:
version: ">=1.10"
version: ">=2.2"
name: python3-django
djangorestframework:
name: python3-djangorestframework
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment