Update django minimum version to 2.2

Use Django from buster-backports as 1.11 is now deprecated.
16 jobs for fix-398 in 13 minutes and 14 seconds (queued for 4 seconds)
latest
Status Job ID Name Coverage
  Test
passed #116014
amd64
dispatcher-debian-10

00:02:21

passed #116016
amd64
dispatcher-debian-11

00:02:47

passed #116015
amd64
server-debian-10

00:03:08

passed #116017
amd64
server-debian-11

00:05:50

 
  Analyze
passed #116018
amd64-dind
bandit-sast

00:01:06

passed #116019
amd64
black

00:00:57

passed #116020
amd64
code_quality

00:00:36

passed #116025
amd64
codespell

00:00:28

passed #116021
amd64
coverage

00:07:20

60.88%
failed #116022
amd64
dockerfiles

00:00:28

passed #116024
amd64
pylint

00:03:35

passed #116023
amd64
schemas

00:00:42

 
  Build
skipped #116027
amd64
debian/10
skipped #116026
amd64
doc
skipped #116028
amd64-dind
docker-amd64-dispatcher
skipped #116029
amd64-dind
docker-amd64-server
 
Name Stage Failure
failed
dockerfiles Analyze
     apt-get install --no-install-recommends --yes python3-voluptuous python3-yaml && \
- apt-get install --no-install-recommends -t buster-backports --yes python3-aiohttp python3-celery python3-django python3-django-auth-ldap python3-django-filters python3-django-tables2 python3-djangorestframework python3-djangorestframework-extensions python3-djangorestframework-filters python3-docutils python3-eventlet python3-jinja2 python3-junit.xml python3-psycopg2 python3-requests python3-simplejson python3-tap python3-tz python3-voluptuous python3-whitenoise python3-yaml python3-zmq && \
+ apt-get install --no-install-recommends --yes python3-aiohttp python3-celery python3-django python3-django-auth-ldap python3-django-filters python3-django-tables2 python3-djangorestframework python3-djangorestframework-extensions python3-djangorestframework-filters python3-docutils python3-eventlet python3-jinja2 python3-junit.xml python3-psycopg2 python3-requests python3-simplejson python3-tap python3-tz python3-voluptuous python3-whitenoise python3-yaml python3-zmq && \
apt-get install --no-install-recommends --yes python3-pip && \
python3 -m pip install sentry-sdk==0.17.2 && \
find /usr/lib/python3/dist-packages/ -name '__pycache__' -type d -exec rm -r "{}" + && \ ]
+ exit 1
Cleaning up file based variables
ERROR: Job failed: exit code 1